Seeker Firmware v 2.07

For assistance with any installation, please call tech support at (800) 344-2412.

This firmware is appropriate for most users, but some MSO's have different update policies in place. In some cases the standard firmware may render certain test functions inoperable. Please contact your manager before updating your firmware.

This firmware update requires Seeker Setup Software Version 3.52 to configure your Seeker Instrument. Please contact Trilithic Applications Engineering Support to obtain a free software update.

v 02.07

  • Added a truck squelch parameter (Requires Seeker Setup v.3.52 or later to work correctly).

v 02.04

  • Enhanced temperature compensation